April 21, 2015 hotro@hostingviet.vn 02466.567.555       Giới thiệuTuyển dụng    Liên hệ   Đăng nhập   Đăng ký

Tôi phải làm sao khi thấy điều này trong bản quản trị Wordpress "Yêu cầu cập nhật PHP"

khi đăng nhập wp-admin, tôi thấy cảnh báo này. Vậy tôi phải làm sao và nó có ảnh hưởng đến website của tôi không?

Chi tiết thông báo:

Yêu cầu cập nhật PHP

WordPress phát hiện bạn đang sử dụng phiên bản PHP không an toàn.

PHP là gì và nó ảnh hưởng như nào đến trang web của tôi?
PHP là ngôn ngữ lập trình mà chúng tôi sử dụng để xây dựng và duy trì WordPress. Các phiên bản mới hơn của PHP đều nhanh và an toàn hơn, do đó, việc cập nhật sẽ có tác động tích cực đến hiệu suất của trang web của bạn.

Yêu cầu cập nhật php

Vậy "Yêu cầu cập nhật PHP" là gì?

khi Bạn nhìn thấy yêu cầu này, có nghĩa rằng Wordpress đã phát hiện Hosting / Server của Bạn đang sử dụng phiên bản cũ đã lỗi thời. Wordpress khuyên Bạn nên cập nhật bản mới hơn để đảm bảo bảo mật và tốc độ cũng nhanh hơn.

Tôi phải làm gì khi thấy "Yêu cầu cập nhật PHP" từ trong bảng quản trị Wordpress

Điều Bạn cần làm là nâng cấp phiên bản PHP từ Hosting hoặc Server. Hãy làm theo các hướng dẫn dưới đây

Nâng cấp phiên bản PHP với Hosting DirectAdmin

[YOUTUBE]

Xin lưu ý:

Xin lưu ý: nếu Bạn sử dụng VPS cài DirectAdmin mà không sử dụng Cloudlinux, hãy tùy chọn phiên bản PHP trong phần "domain setup"

Nếu Bạn chưa thực hiện được, vui lòng chat với HostingViet ở góc phải phía dưới màn hình này, HostingViet sẽ xử lý giúp Bạn!

Nâng cấp phiên bản PHP với Hosting cPanel

Bước 1: Đăng nhập Hosting

Bước 2: Gõ "php" trên thanh tìm kiếm của cPanel, sau đó Click "Select PHP Version"

Bước 3: Chọn phiên bản PHP 7.x và lưu lại

Bước 4: Kiểm tra lại 

Nâng cấp phiên bản PHP với Controlpanel khác nói chung

Nhìn chung Bạn có thể nâng cấp nếu: Server có cài đặt nhiều phiên bản PHP

Tùy từng controlpanel, Bạn hãy tìm đến chỗ nào có "PHP" "Version" là sẽ có tùy chọn tương tự cPanel và DirectAdmin ở trên

Các lỗi có thể xảy ra khi nâng cấp phiên bản PHP

Lỗi là điều có thể xảy ra nếu: 

  • Source Code của Bạn không tương thích với phiên bản PHP mới. điều này thường xảy ra khi lập trình viên sử dụng hàm PHP nào đó ở phiên bản cũ, không được hỗ trợ ở phiên bản PHP mới. Nếu điều này xảy ra, Bạn hãy tìm kiếm thông tin liên quan đến lỗi mà Bạn gặp phải. Hoặc đơn giản hơn nếu Bạn sử dụng Hosting / VPS / Server tại HostingViet, Bạn chỉ cần gửi 1 ticket là xong!
  • Xung đột Theme
  • Xung đột Plugin

Core của Wordpress thì chắc chắn không bị lỗi

Tác giả:

Trung @HostingViet Tech